NO

Author Topic: add compiler option to make exe "large memory aware&quo  (Read 2715 times)

Offline Stefan Pendl

  • Global Moderator
  • Member
  • *****
  • Posts: 565
    • Homepage
add compiler option to make exe "large memory aware&quo
« on: July 05, 2006, 07:34:06 PM »
Pelle,
is there a way to include an option to make Windows exes aware of large memory (WinXP /3GB boot.ini option) ???
I know that there is a little tool to do this, but saving this wit the project would be cleaner and easyer to handle.

Thanks for listening.
---
Stefan

Proud member of the UltraDefrag Development Team

Offline Pelle

  • Administrator
  • Member
  • *****
  • Posts: 1923
    • http://www.smorgasbordet.com
Re: add compiler option to make exe "large memory aware
« Reply #1 on: August 04, 2006, 11:05:43 AM »
Use "Project" -> "Project options", "Macros" tab, and manually edit the "LINKFLAGS" macro (add /LARGEADDRESSAWARE option). This *should* work...
/Pelle

Offline Stefan Pendl

  • Global Moderator
  • Member
  • *****
  • Posts: 565
    • Homepage
add compiler option to make exe "large memory aware&quo
« Reply #2 on: August 07, 2006, 09:54:23 PM »
Thanks Pelle, will try that.
---
Stefan

Proud member of the UltraDefrag Development Team

skywalk

  • Guest
Re: add compiler option to make exe "large memory aware
« Reply #3 on: October 06, 2015, 06:34:42 PM »
Use "Project" -> "Project options", "Macros" tab, and manually edit the "LINKFLAGS" macro (add /LARGEADDRESSAWARE option). This *should* work...
Sorry to bump old topic, but it is still relevant to me.
I also asked here?

Offline TimoVJL

  • Global Moderator
  • Member
  • *****
  • Posts: 1612
Re: add compiler option to make exe "large memory aware&quo
« Reply #4 on: October 07, 2015, 06:29:12 AM »
There are polink option /LARGEADDRESSAWARE and /LARGEADDRESSAWARE:NO only.
Same as ms link.exe

Code: [Select]
Syntax:
/LARGEADDRESSAWARE [:NO]
May the source be with you

skywalk

  • Guest
Re: add compiler option to make exe "large memory aware&quo
« Reply #5 on: October 07, 2015, 02:34:00 PM »
Thanks, that worked!
I used /LARGEADDRESSAWARE:YES  :-[