NO

Author Topic: Problem with Listview InsertItem  (Read 78 times)

Offline Jokaste

  • Member
  • *
  • Posts: 37
  • Never be pleased, always improve.
    • ImgTools
Problem with Listview InsertItem
« on: September 26, 2017, 05:05:31 PM »
I have attached a entire asm program ! It is ok for all points except, it does not show the good image.


The program downloads all the image in https://commons.wikimedia.org/wiki/Accueil.
The downloaded files are stored into "My Pictures" folders.
After this step, I add the image to a image list.
After this step I insert an item (LVIF_IMAGE)
At the end, all the images are the same!


I wanted to finish the program to show you what I wrote in asm, but I can't.
There is a bug when you make the right-click (I wil correct it later).
I will give the user the possibility to select an URL.


For using the program, just right click on the window, all around the listview.
It did not catch the NM_CLICK for now.


If you could help me I appreciate very much.


Philippe RIO
http://imgtools.monsite-orange.fr/
« Last Edit: September 27, 2017, 02:16:05 PM by Jokaste »
Kenavo

Offline Jokaste

  • Member
  • *
  • Posts: 37
  • Never be pleased, always improve.
    • ImgTools
Re: Problem with Listview InsertItem
« Reply #1 on: September 27, 2017, 02:14:33 PM »
I have found the error. It is a bad alignment of pszText member in the LVITEM structure. I have added four padding bytes and it is OK.


Philippe RIO
http://imgtools.monsite-orange.fr/
« Last Edit: September 27, 2017, 02:16:50 PM by Jokaste »
Kenavo

Offline Jokaste

  • Member
  • *
  • Posts: 37
  • Never be pleased, always improve.
    • ImgTools
Final Version
« Reply #2 on: September 27, 2017, 06:54:56 PM »
Kenavo