NO

Author Topic: InpOut32 for PellesC  (Read 26415 times)

Anonymous

  • Guest
InpOut32 for PellesC
« Reply #30 on: May 01, 2005, 11:36:06 am »
Quote from: "tiwag"

have you tried to disable the FIFO settings in "advanced port setting" ?
just slide completely to the left or uncheck the option, if there is a checkbox.


Ummm... I hadn't thought of that, but what effect would this have?  
(aside from the obvious disabling of the on-chip buffers, that is)

tiwag

  • Guest
InpOut32 for PellesC
« Reply #31 on: May 01, 2005, 11:37:03 am »
Quote from: "ldblake"
Quote from: "tiwag"

have you tried to disable the FIFO settings in "advanced port setting" ?
just slide completely to the left or uncheck the option, if there is a checkbox.


Ummm... I hadn't thought of that, but what effect would this have?  
(aside from the obvious disabling of the on-chip buffers, that is)


sometimes it works afterwards  :P

JohnF

  • Guest
InpOut32 for PellesC
« Reply #32 on: May 01, 2005, 11:38:26 am »
Quote from: "tiwag"
Quote from: "JohnF"

... The best thing is to find another driver, thanks for your input...


if they are from M$, named
serenum.sys and
serial.sys
and have a description which correlates to the installed XP Sservice pack
(here i have XP SP2 and the drivers are of version (xpsp_sp2_rtm.040803-2158))
then let them as they are!


2nd)
have you tried to disable the FIFO settings in "advanced port setting" ?
just slide completely to the left or uncheck the option, if there is a checkbox.

-tiwag


Yes, I've tried it disabled and enabled.

I have sp1

sernum.sys    5.1.2600.0(XPClient 010817-11-48
serial.sys     5.1.2600.1106 (xpsp1.020828-1920)

John

tiwag

  • Guest
InpOut32 for PellesC
« Reply #33 on: May 01, 2005, 11:40:54 am »
Quote from: "JohnF"
Yes, I've tried it disabled and enabled.

I have sp1

sernum.sys    5.1.2600.0(XPClient 010817-11-48
serial.sys     5.1.2600.1106 (xpsp1.020828-1920)

John


interesting, i have both drivers from the same version,
maybe this produces troubles at your side.

tiwag

JohnF

  • Guest
InpOut32 for PellesC
« Reply #34 on: May 01, 2005, 12:47:58 pm »
Quote from: "tiwag"
Quote from: "JohnF"
Yes, I've tried it disabled and enabled.

I have sp1

sernum.sys    5.1.2600.0(XPClient 010817-11-48
serial.sys     5.1.2600.1106 (xpsp1.020828-1920)

John


interesting, i have both drivers from the same version,
maybe this produces troubles at your side.

tiwag


It's strange that both the Device Manager and DELL diagnostics say the port is ok. Btw, on my old machine where COM1 is not working with the termial app and COM 2 does work, both ports have FIFO enabled.

I'll forget it for now, there does not seem to be an obvious solution.

John

Anonymous

  • Guest
InpOut32 for PellesC
« Reply #35 on: May 01, 2005, 01:14:52 pm »
Quote from: "JohnF"

I'll forget it for now, there does not seem to be an obvious solution.


It does seem a little odd.  These days the comports are integrated into the chipsets, seems to me that if one works both should... and it's really odd that you have two machines and the same problem on both.

If you ever do get it sorted can you let us know what you did...  Might be handy info at some point in time.