NO

Author Topic: Workspace bug  (Read 258 times)

Offline Grincheux

  • Member
  • *
  • Posts: 48
  • Never be pleased, always improve
    • Arachne
Workspace bug
« on: July 18, 2020, 07:54:54 am »



I would like to get the Chloe project properties...
I don't understand why there is no active mode, it is "Release" for two projects and "Debug" for the first.
I created all the projects one by one and the workspace did not exist.
When all projects where OK, I created the workspace.
Can you help me?

-------------------------
Kenavo

Offline Pelle

  • Administrator
  • Member
  • *****
  • Posts: 2064
    • http://www.smorgasbordet.com
Re: Workspace bug
« Reply #1 on: July 18, 2020, 02:21:50 pm »
The IDE insists that all projects in a workspace must be in the same "mode" (Debug/Release/...). If not, things will get really weird.
If you import projects with different "modes" you get into a mixed state, which sounds like your problem.

The easy fix is just to select a mode from the combobox on the toolbar. The IDE will select this mode for all projects (assuming all projects have this mode!).

Use "View" -> "Target files" to check the mode for each project. At the end of each project is should normally say "(Debug)" or "(Release)". If it just says "()" something is wrong. Do the above easy fix.
/Pelle

Offline Grincheux

  • Member
  • *
  • Posts: 48
  • Never be pleased, always improve
    • Arachne
Re: Workspace bug
« Reply #2 on: July 18, 2020, 08:00:02 pm »
OK
Thanks
-------------------------
Kenavo