NO

Author Topic: 5.00.1 - create new icon bug (also present in previous versions).  (Read 2158 times)

aj

  • Guest
I'm using the new 5.00.1 version of Pelles C (32-bit) on XP SP2, and I'm experiencing some minor (but still very annoying) issues with icons and the resource editor.

I create a new resource, then a new icon and make a nice icon in the built-in icon-editor. Saves the icon ("icon.ico"), chooses a good ID for my icon (ID_ICON) and saves the resource to for example "resource.rc" and then the header ("resource.h") for the ID, compiles my program and then...
The resource still looks for the default name "res1.ico" such that the .rc-file is looking something like this:

Code: [Select]
...
ID_ICON ICON "res1.ico"
Which means that I have to edit the .rc-file by hand (notepad), for it to work.

Offline Pelle

  • Administrator
  • Member
  • *****
  • Posts: 2034
    • http://www.smorgasbordet.com
Re: 5.00.1 - create new icon bug (also present in previous versions).
« Reply #1 on: June 14, 2008, 05:07:00 pm »
You mean saving icon.ico through File/Save ??! This has nothing to do with the resource creation process. You should look at 'Properties' for the icon (in the resource tree). The 'Filename' field holds the associated filename for the resource. It will be empty for a new resource, and given a default name when saved (like res1.ico). You can change the name at any time. See the help file. No bug here, AFAICT...
/Pelle

aj

  • Guest
Re: 5.00.1 - create new icon bug (also present in previous versions).
« Reply #2 on: June 14, 2008, 09:32:35 pm »
Well, then maybe it's more of a feature request... :)

It's just that the icon-"editing" and icon-"in resource" is split from each other. So that when saving the icon it's not also saved in the resource (at least not the first time around).

For me it feels like I'm dealing with the same thing/icon here. If you look at the tab when opening the icon (double-click from the "resource.rc"-view) it says "resource.rc ID_ICON (Icon)" but that's not quite true until the paths match.
I know it might feel like a minor issue, but I'd (boldly) suggest that you'd try to creating a couple of icons and see if it feels natural when saving them.

Offline Pelle

  • Administrator
  • Member
  • *****
  • Posts: 2034
    • http://www.smorgasbordet.com
Re: 5.00.1 - create new icon bug (also present in previous versions).
« Reply #3 on: June 18, 2008, 12:44:58 am »
It's the least bad thing, I guess. Somtimes I want to save an icon without the new name going into the resources. This can be handled in other ways, but not without a fair amount of work. Unfortunately this puts this request on the "not very urgent" list...
/Pelle