NO

Author Topic: A question about mixing versions....  (Read 2797 times)

CommonTater

  • Guest
A question about mixing versions....
« on: December 16, 2011, 09:56:37 pm »
What would be the consequences of using the 6.50 POIDE, headers, libs etc... with the 6.00 compiler?
 
I've tried it experimentally... but I'm wondering if there's a hidden "gotcha" waiting...
 
 

Offline Bitbeisser

  • Global Moderator
  • Member
  • *****
  • Posts: 761
Re: A question about mixing versions....
« Reply #1 on: December 17, 2011, 12:54:12 am »
You're trying to get around the optimization bug you posted?  ???

Ralf

CommonTater

  • Guest
Re: A question about mixing versions....
« Reply #2 on: December 17, 2011, 01:43:52 am »
You're trying to get around the optimization bug you posted?  ???

Ralf

Yep... I was wondering if dropping in the earlier compiler was a safe thing to do until the problem is fixed ... I can go back to 6.00 entirely, but then I have to rebuild all my project files because of the imbedded versions... So it seemed easier to just swap out POCC and go from there...

CommonTater

  • Guest
Re: A question about mixing versions....
« Reply #3 on: December 17, 2011, 08:46:07 pm »
Sorry to bump this... but it's a priority for me to find this out....

Anyone?


Offline Bitbeisser

  • Global Moderator
  • Member
  • *****
  • Posts: 761
Re: A question about mixing versions....
« Reply #4 on: December 17, 2011, 10:06:00 pm »
Sorry, I can't tell you more than what you might have found out yourself.
Just using the IDE should certainly be fine, don't think that there is a problem with using libs or headers unless something in the calling convention would have changed...

Btw, have you tried to use an earlier 6.50 release to find out when this issue was possibly introduced?

Ralf

CommonTater

  • Guest
Re: A question about mixing versions....
« Reply #5 on: December 17, 2011, 11:17:41 pm »
Sorry, I can't tell you more than what you might have found out yourself.
Just using the IDE should certainly be fine, don't think that there is a problem with using libs or headers unless something in the calling convention would have changed...

Btw, have you tried to use an earlier 6.50 release to find out when this issue was possibly introduced?

Ralf

Apparently it began with 6.50 and has been there since the beginning.  RC1 had it...  Also note a similar problem has been cited on this forum before but never fully tracked down. 

I don't think it's a flaming diasater or anything like that... but since it was first raised on a different forum I've found a few spots in my own code where pointer manipulations have gone wrong, quite possibly because of it.
 
So if possible, I'd like to side step the problem and with the current snails pace of updates, I thought reverting the compiler back a version might be a good solution... although I can also just compile new code with the optimizations off for now.
« Last Edit: December 17, 2011, 11:21:19 pm by CommonTater »

CommonTater

  • Guest
Re: A question about mixing versions....
« Reply #6 on: December 18, 2011, 05:23:04 am »
Addendum.... I've done some further experimenting and updated the bug report to note that it only appears to be a problem with pointers to string literals... which is sufficiently obscure that I can ignore it for the time being.