NO

Author Topic: "native" linker setting...  (Read 4239 times)

CommonTater

  • Guest
"native" linker setting...
« on: May 29, 2012, 06:32:05 pm »
Project -> Project Options -> Linker -> Subsystem = Native 
 
Can someone give me a brief explaination of this linker setting, when it's used and in conjunction with what kind of project?
 
Thanks.
 
 

Offline AlexN

  • Global Moderator
  • Member
  • *****
  • Posts: 391
    • Alex's Link Sammlung
Re: "native" linker setting...
« Reply #1 on: May 29, 2012, 07:13:03 pm »
Project -> Project Options -> Linker -> Subsystem = Native 
 
Can someone give me a brief explaination of this linker setting, when it's used and in conjunction with what kind of project?
 
Thanks.
What says the help (Command line tools -> Polink -> Commanline options -> /subsystem -> Native:

NATIVE is used for Windows NT drivers.
best regards
 Alex ;)

Online Vortex

  • Member
  • *
  • Posts: 531
    • http://www.vortex.masmcode.com
Re: "native" linker setting...
« Reply #2 on: May 29, 2012, 08:00:42 pm »
Hi CommonTater,

This setting enables also to code an application running before the complete system boot like chkdsk checking for disk errors.
Code it... That's all...

CommonTater

  • Guest
Re: "native" linker setting...
« Reply #3 on: May 29, 2012, 08:01:09 pm »
Project -> Project Options -> Linker -> Subsystem = Native 
 
Can someone give me a brief explaination of this linker setting, when it's used and in conjunction with what kind of project?
 
Thanks.
What says the help (Command line tools -> Polink -> Commanline options -> /subsystem -> Native:

NATIVE is used for Windows NT drivers.


So what kind of project do I create for that?  A DLL?

aardvajk

  • Guest
Re: "native" linker setting...
« Reply #4 on: May 29, 2012, 08:17:39 pm »
None. PellesC doesn't come with the required include files for either drivers or a user-mode native program.

Online Vortex

  • Member
  • *
  • Posts: 531
    • http://www.vortex.masmcode.com
Re: "native" linker setting...
« Reply #5 on: May 29, 2012, 08:21:23 pm »
Mark Russinovich's article : Inside Native Applications

http://technet.microsoft.com/en-us/sysinternals/bb897447.aspx
Code it... That's all...

CommonTater

  • Guest
Re: "native" linker setting...
« Reply #6 on: May 29, 2012, 09:10:03 pm »
Ok... thanks for the help guys...

It looks like I don't want to go there with what I had in mind.  :D






Offline Stefan Pendl

  • Global Moderator
  • Member
  • *****
  • Posts: 567
    • Homepage
Re: "native" linker setting...
« Reply #7 on: May 30, 2012, 09:30:16 pm »
The boot time interface of UltraDefrag is a native application and there is the native-nt-toolkit at http://native-nt-toolkit.googlecode.com/svn/trunk

They all need to link to ntdll.dll ;)

Quote
Sysinternals Freeware - Inside the Native API
    http://netcode.cz/img/83/nativeapi.html

Native API function documentation
    http://undocumented.ntinternals.net/

Listing of the NT Native API  functions
    http://jedi-apilib.sourceforge.net/native/NativeList.html

Inside Native Applications
    http://technet.microsoft.com/en-us/sysinternals/bb897447.aspx

Native Windows API Programmierung (German)
    http://www.ks.uni-freiburg.de/download/studienarbeit/SS07/09-07-napi-jrudolph/NativeAPI-ComputernameChanging.pdf

Windows System Call Table (NT/2000/XP/2003/Vista)
    http://metasploit.com/users/opcode/syscalls.html
---
Stefan

Proud member of the UltraDefrag Development Team

Online Vortex

  • Member
  • *
  • Posts: 531
    • http://www.vortex.masmcode.com
Re: "native" linker setting...
« Reply #8 on: May 30, 2012, 09:33:38 pm »
Code it... That's all...

Offline Stefan Pendl

  • Global Moderator
  • Member
  • *****
  • Posts: 567
    • Homepage
Re: "native" linker setting...
« Reply #9 on: May 30, 2012, 09:39:38 pm »
Seems the way-back machine has to be used for those lost web library books if possible.

Collecting links isn't reliable any more :(
---
Stefan

Proud member of the UltraDefrag Development Team

Online Vortex

  • Member
  • *
  • Posts: 531
    • http://www.vortex.masmcode.com
Re: "native" linker setting...
« Reply #10 on: June 08, 2012, 02:03:21 pm »
Code it... That's all...