NO

Author Topic: POIDE v 2.80.10 Project bug  (Read 3411 times)

post from old forum

  • Guest
POIDE v 2.80.10 Project bug
« on: September 14, 2004, 12:49:52 am »
Hi Pelles,

Thanks for your great product!

I don't know if this is a known bug, but if you have created a project and you are working with it for a while and then you create a new file and go to save it for the first time it will ask if you want to add it to the open project. This works fine, but after it adds it to the project it makes the project explorer on the side load all the files by there full file path, not just the file name as before. This is very anoying. The only thing I can do is create a new project and add all the files again.

A second little bug is if you create a new file and paste some code into the empty file, if it doesn't have an extra new line at the end when you click to the line at the end it doesn't put the cursor at the end of the line it puts it 1 character to the left. Hope you can understand that.

_____________________________
- Ryan
http://rjpcomputing.com

post from old forum

  • Guest
POIDE v 2.80.10 Project bug
« Reply #1 on: September 14, 2004, 12:50:15 am »
Hello Ryan,

Thanks!

I have seen something similar myself. When adding a new file to the project, I always try to find the 'best path' for all project files (in case the source files are located in *different* directories). I used a case-sensitive compare of the file paths, which caused problems. I have now changed it to a case-insensitive compare in the upcoming v2.90.

I will look at the paste problem. I guess it's special case #5463

Pelle